Zmodem issues

The name says it all!
Fri Apr 11, 2014 10:15 pm


  • As an ex-scener it's great to see there's still an interest in /X :)

    So, to kick off this forum - I've got /X v4.12 working with telnet under Win-UAE (and FS-UAE) using the bsdsocket.library and I'm having serious Zmodem problems. Uploading with Zmodem either CRC-fails at a random point during the upload or if it completes, it freezes. Anyone else had problems with the internal Zmodem?
    vOODOO
     
    Posts: 2
    Joined: Fri Apr 11, 2014 9:45 pm

Sat Apr 12, 2014 3:48 pm


  • Great first post!
    Just to confirm a few things, is this happening when you call other boards and try uploading/downloading?
    Does this only happen on your Amiexpress BBS?
    I did find this post on another forum, which may help.

    If you find a resolution please post it.

    Original Post:

    http://eab.abime.net/showthread.php?t=3274&page=6
    ________________________________
    Zmodem uploads crashing the system
    I am making progress on the ZMODEM issue. Contrary to what was stated earlier in thise thread, Ami-X 4.XX supports XPR libraries right out of the box with no door needed. They did create a door for HYDRA so people could get up and running without understanding XPR libraries. It appears that there is also a zmodem internal protocol that is set up by default which is likely incompatible with telnet or telnet settings. My challenge right now is to figure out the exact syntax for the xprzmodem.info tooltype, which version of the xprzmodem library works with telnet if any, and which xprzmodem options need to be set for the tooltype to work effectively.

    i've only found some generic options within the ae-4 manual:

    Code:
    <XFERLib>.INFO - This ICON tooltypes specify the options for
    ~~~~~~~~~~~~~~ for each XFERLibrary you use in your BBS system.
    e.g.: XPRZmodem.INFO = xprzmodem.library
    XPRYmodem.INFO = xprymodem.library
    This ICON should be placed in the BBS:Protocols/
    directory.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    OPTIONS=<opt> - Allowed you to specify the Options for the
    XFERLibraries.
    e.g.: OPTIONS=TN,AY,OR,KY,SN,RN,DN,F0,B32
    AE_BATCH - All batch protocol icons must contain the tooltype
    AE_BATCH instead of Batch.
    and in the current aminet xprzmodem (v2.56) docs, you can read this:
    Code:
    The default option settings if you don't change anything are "TC, ON, B16, F0,
    E10, AY, DN, KY, SN, RN, P".
    User avatar
    Black Beard
     
    Posts: 48
    Joined: Sun Mar 30, 2014 9:17 pm

Sat Apr 12, 2014 6:15 pm

Sat Apr 12, 2014 11:23 pm


  • Thanks for the reply! I read the eab.abime.net threads earlier (that's where I got the version of /X I'm using) and although Zmodem/uploading issues were reported by others, I couldn't find anyone who posted a resolution. That being said, I had some time last night to play with my setup and I believe I have fixed my Zmodem issues:

    Crashing and freezing:
    I'm not _entirely_ sure what was causing this, but it appeared to be a KS/WB issue or something related to the UAE config. A clean install with the following UAE settings gave me an almost-working Zmodem:
    KS: 3.1 (amiga-os-310-a4000.rom)
    WB: 3.1 (amiga-os-310-workbench.adf)
    CPU: Amiga 4000 (68040)
    Chip RAM: 8mb
    ZIII RAM: 16mb
    Picasso enabled
    bsdsocket.library enabled (no need to install AmiTCP or any other stack)

    CRC/ZRPOS errors:
    After installing the above, Zmodem uploads no-longer froze completely but still had random CRC/ZRPOS errors. This was caused by baudrate mismatching in my /X config. I fixed this with:
    "SERIAL.BAUD=19200" in the tooltypes of bbs:nodeX/serial/internal_unit.info
    "<port> <nodes> pacerate 19200 255.255.255.255" in bbs:amitcp/db/telnetd-device.config

    So, now the fun begins... spending hours editing tooltypes and installing doors :)
    vOODOO
     
    Posts: 2
    Joined: Fri Apr 11, 2014 9:45 pm

Mon Apr 14, 2014 10:43 pm

Thu May 08, 2014 11:27 am


  • I ran into this the other day, and it occurred mostly on larger files.
    My fix was to use mtelnet instead of syncterm, now the issue is gone.
    Test this out and let me know if it helps.

    Black Beard
    User avatar
    Black Beard
     
    Posts: 48
    Joined: Sun Mar 30, 2014 9:17 pm

Thu Feb 26, 2015 11:17 am


  • Have you guys found anything good for doing batch uploads? Im currently using Zoc Term but it seems to cause the odd crash of /X
    ordyne
     
    Posts: 18
    Joined: Wed Apr 09, 2014 10:02 am

Sat Dec 19, 2015 3:35 pm


  • vOODOO wrote:Thanks for the reply! I read the eab.abime.net threads earlier (that's where I got the version of /X I'm using) and although Zmodem/uploading issues were reported by others, I couldn't find anyone who posted a resolution. That being said, I had some time last night to play with my setup and I believe I have fixed my Zmodem issues:

    Crashing and freezing:
    I'm not _entirely_ sure what was causing this, but it appeared to be a KS/WB issue or something related to the UAE config. A clean install with the following UAE settings gave me an almost-working Zmodem:
    KS: 3.1 (amiga-os-310-a4000.rom)
    WB: 3.1 (amiga-os-310-workbench.adf)
    CPU: Amiga 4000 (68040)
    Chip RAM: 8mb
    ZIII RAM: 16mb
    Picasso enabled
    bsdsocket.library enabled (no need to install AmiTCP or any other stack)

    CRC/ZRPOS errors:
    After installing the above, Zmodem uploads no-longer froze completely but still had random CRC/ZRPOS errors. This was caused by baudrate mismatching in my /X config. I fixed this with:
    "SERIAL.BAUD=19200" in the tooltypes of bbs:nodeX/serial/internal_unit.info
    "<port> <nodes> pacerate 19200 255.255.255.255" in bbs:amitcp/db/telnetd-device.config

    So, now the fun begins... spending hours editing tooltypes and installing doors :)


    This fixed my issue. Thanks
    Shadower
     
    Posts: 1
    Joined: Fri Jan 09, 2015 4:17 pm



Return to Troubleshooting AmiExpress




Information
  • Who is online
  • Users browsing this forum: No registered users and 1 guest
cron